Ubuntu 14.04 fails to update

Updates may fail due to the apt package being out-of-date.

wget http://security.ubuntu.com/ubuntu/pool/main/a/apt/apt_1.0.1ubuntu2.17_i386.deb
sudo dpkg -i apt_1.0.1ubuntu2.17_i386.deb
sudo do-release-upgrade (if this fails, download the next version of the apt package below)

wget http://security.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg_1.17.5ubuntu5.6_i386.deb
sudo dpkg -i dpkg_1.17.5ubuntu5.6_i386.deb

Leave a Comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.